Netzlaufwerke automatisch beim Systemstart verbinden

  • Windows 7
  • Windows 8
  • Windows 10

Achtung: Diese Seite ist nur noch Teil eines Archivs und wird in Zukunft entfernt.

In Windows gibt es die komfortable Möglichkeit, über Netzlaufwerke direkt im Windows-Explorer mit Festplatten auf anderen Computern im Netzwerk zuzugreifen. Leider funktioniert hier die automatisierte Funktion selten. Man ist zwar in der Lage, Login-Daten hierfür zu hinterlegen, um sich automatisch mit dem Netzwerk zu verbinden, allerdings wartet das System nicht auf das Netzlaufwerk beim Start.

Dadurch kommt es oftmals dazu, dass das Netzlaufwerk erst einmal "aufwachen" muss und man dadurch die Meldung erhält, dass die Verbindung zu einigen Netzlaufwerken nicht wiederhergestellt werden konnte.

Abhilfe kann man durch eine kleine Batch-Datei schaffen, welche nochmals beim Login eine Anfrage an das Netzlaufwerk sendet, das bis dahin aufgewacht sein sollte. Diese sieht folgendermaßen aus:

Quellcode

  1. @echo off
  2. cls
  3. echo Verbinde Netzlaufwerk
  4. echo.
  5. net use X: \\Netzlaufwerk\Pfad /user:Benutzername Passwort
  6. echo.
  7. echo Verbindung erfolgreich
  8. exit
Hier muss Zeile 5 noch angepasst werden:
X:gibt den Laufwerksbuchstaben an, der genutzt werden soll.
\\Netzlaufwerk\Pfadgibt den Netzwerkpfad zum Netzlaufwerk an.
UnterBenutzernamegibt man den Benutzernamen an, falls benötigt.
UnterPasswortgibt man das Passwort an, falls benötigt.

Gespeichert ist die Datei bei mir unter network.bat.

Falls man sie automatisch beim Systemstart laden möchte, kann man sie in eines der folgenden Verzeichnisse laden.
Für den generellen Systemstart bei jedem Benutzer:
%ProgramData%\Microsoft\Windows\Start Menu\Programs\StartUp
Für den Systemstart des aktuell angemeldeten Benutzers:
%appData%\Microsoft\Windows\Start Menu\Programs\StartUp
Über den Autor
Ich bin Webentwickler in Stuttgart und administriere Server seit vielen Jahren. In diesem Blog erstelle ich hauptsächlich Tutorials für andere Webentwickler, Webdesigner und Serveradministratoren.
-------------------------------------------------------------------------------------------------------------------------------------
I’m a web developer in Stuttgart, Germany, and server administrator since many years. This blog mainly contains a tutorial set for other web developer, web designer and server administrators.

63.979 mal gelesen

Kommentare 10

  • Smarki -

    Danke für die schnelle Antwort Black Rider.

    Leider hat es dadurch immer noch nicht funktioniert. Es wird weiterhin nur das oberste Laufwerk angezeigt. Ich habe Namen, IP-Adresse, Benutzername und Passwort nochmal überprüft, jedoch klappt es nicht besser;(. Hast du oder jemand anders vielleicht noch eine Idee?

    Vielen Dank im vorraus

  • Black Rider -

    Statt es in Zeile 5 zu schreiben, wiederhole Zeile 5–7 bitte für jedes Laufwerk. Möglicherweise funktioniert das.

  • Smarki -

    Ich hatte auch das selbe Problem...

    Jetzt habe ich die Batch Datei und es funktioniert beim ersten Laufwerk. Alle Nachfolgenden Laufwerke die ich unter die 5. Zeile gemacht hab (Identisch mit Zeile 5, nur angepasst an andere Ordner) erscheinen nicht. Kann mir jemand helfen?

    LG
    Smarki

  • hallomann -

    @christian:
    Ist ja auch richtig.

  • Black Rider -

    Wie das Icon aussieht, ist egal. Wenn das Netzlaufwerk bei einem Doppelklick direkt erreichbar ist, hat das Script genau das erreicht, was es erreichen sollte.

  • chris-1 -

    das Icon ändert sich nicht, auch nicht nach 10 Minuten...
    erst nach einem doppelklick ist auch das Laufwerk ereichbar.

  • Black Rider -

    Bitte bedenke, dass diese Batch-Datei nur dazu dient, dass die NAS sofort erreichbar ist. Es kann durchaus sein, dass Windows nicht sofort das Icon korrigiert, das ist bei mir auch der Fall.

    Es dient nur dazu, dass das Netzlaufwerk aufwacht und man ohne Wartezeit darauf zugreifen kann.

  • chris-1 -

    habe die Datei nun als Network.batch.cmd abgespeichert.
    eingabefenster schließt jetzt gleich.
    aber das rote X ist immer noch drin!
    erst duch doppelklick öffnet sich das laufwerk und rotes X ist weg.
    da es sich hierbei um ein NAS handelt müsste sich das netzlaufer\order gleich verbinden.

  • Black Rider -

    Dass das Fenster kurz erscheint, ist normal. Das sollte allerdings schnell wieder verschwinden und dann mit dem Netzlaufwerk verbunden sein.

    Bist du auch sicher, dass die Pfade stimmen?

  • christian -

    hi

    geht leider nicht, nach dem hochfahren kommt ein dos fenster.....

    keine Ahnung was ich noch machen kann.

    Chris.

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen